Old versions:  The auto-updater in older VM versions was not working correctly on some servers so has been removed from the VirtueMart core as from VM2.6.2.

All updates of the main and aio components may be made using Joomla’s extensions installer or for stable release (even number versions) Joomla’s component updater may be used if an update alert message is shown. I prefer to use the full installer for every update.

The VM file packages can be downloaded from http://dev.virtuemart.net/projects/virtuemart/files

On your local machine unpack com_virtuemart2/3.x.x_extract_first.zip to release the two VM component files. Then install the main component followed immediately by the aio component. It is important to use the same release version aio component. These overwrite and replace the previous installation but no data is deleted.

You must update both components using the same release number  as they are designed to work together.

As always, all updates should be tested first on a backup copy of the live website to ensure no problems with functions, template overrides etc.

Note that the minimum usable PHP version is now 5.3.10